
MAFI: 5CC – The Manual (PC- & Mac-version) 1

File: 5CCManual.PDF
Format: PDF
First release: January 5th, 2006
Last updated: February 20th, 2006
Author: Mafi; closecombat2@claranet.de; http://members.fortunecity.de/closecombat2/
French translation by Martial FFL_Jag, June 2006, of version 1.04

Close Combat series of games

5CC - Le Manuel
(description de 5CC éditeur de map pour PC- & Mac)

Table des matières

Installation et Système............................... 2
Introduction ................................................ 3
Petit guide de création ............................... 4
Barre de menu ........................................... 7
Menu "File"..................................................................7
Fenêtre "Preferences" ................................................10
Barre de menu "Edit".................................................13
Barre de menu "Roof" ...............................................14
Barre de menu "Actions"...........................................14
Barre de menu "Visibility" ........................................15
Barre de menu "Color" ..............................................15
Barre de menu "Help"................................................15
Les fenêtres ............................................. 16
Fenêtre "Editing" .......................................................16
Fenêtre  "Tools" .........................................................17

Fenêtre "Terrain Elements Table".............................21
Fenêtre "Coordinates"................................................22
Fenêtre "OVM" and "MMM"....................................22
Fenêtre "Map properties"...........................................22
Fenêtre "Roof informations" .....................................22
Fenêtre "Visible layers".............................................23
Fenêtre "Trees" ..........................................................23
Concept de double couche.........................................26
Fenêtre "LOS actions" ...............................................26
Tactiques .................................................24
Définition des Roof....................................................28
Définition de l image CC2 bridge .............................31
Définition des datas CC2 bailey bridge ....................32
Sources utilisées et recommandées .......34

Remerciements aux développeurs:
Mick Conmy (mick xe5), Adam 'The Man' D'Arcy (qui a rendu publique le format des fichiers graphiques
des map CC2), Gerry Shaw (aka TinTin), Vincent Viaud (pour la résolution du codage des fichiers LOS),
Andrew (The Naked Foot) Glenn (pour son guide sur la realisation des cartes), The Other Dave (David R.
Tidy, pour son CC2Faq.wri), Chris Ellens (pour CCEdit sur Mac), Cpl_Filth (réalisateur de 3C.exe éditeur
de données pour PC), Sgt_Wilson, kwp ... et tous les autres non cités, qui ont permis le développement des
éditeurs pour Close Combat.

Remerciement special à Martial FFL_Jag pour le translation français et aux beta testeurs Jim Martin,
Francisco Arais "Nembo", Darren Tejszerski "tejszd" and Keith Postuchow "kwp" et tous les autres non cites
ici!

5CC n’est pas avalisé ni promu par les concepteurs originels du jeu. Vous
utilisez ce programme à vos propres risques. Je vous recommande de travailler
uniquement sur des back up de vos fichiers et de sauvegarder le plus souvent
possible!

mailto:closecombat2@claranet.de
http://members.fortunecity.de/closecombat2/


MAFI: 5CC – The Manual (PC- & Mac-version) 2

Installation et Système Requis

Pour installer 5CC copier simplement le programme sur votre disque dur. Je vous recommande de
créer un dossier séparé pour, et de mettre les fichiers l’accompagnant (manual, readmes, terrain
elements files) au même endroit.

La version PC de 5CC fonctionne sous les systèmes Win95, Win98 et WinXP.
La version Mac de 5CC est une application carbone et fonctionne sous MacOS-X 10.2.8 ou plus
récent (PPC processor) et sous  MacOS 8.5 – 9.2.2 (avec CarbonLib 1.6 ou plus). Vous devez être
sûr d’avoir assez de mémoires pour que 5CC fonctionne normalement (plus de 100 MB) RAM
sous MacOS ! Sous peine de crash système avec évidement la perte de vos données!

5CC stocke les données de votre map entièrement en RAM, aussi vous aurez besoin d’une grande
quantité de mémoire pour faire fonctionner 5CC avec les maps les plus larges. Quelques exemples
de calculs:

pour une map de  20x20 en « deployment tile » (= 2400x2400 pixels) vous aurez besoin:
pour codage d’objet basique:      5000 KB
table de donnée interne map:       450 KB
table de donnée LOS:     2500 KB
background graphic:   11250 KB
graphique int additionnel:   11250 KB
couche additionnel shadow/trunk:   33750 KB
graphique OVM et MMM:     1500 KB
affectation de 50 entrée roof:     7800 KB

-----------------------
  63600 KB

pour une map de40x40 standard RtB/CCM (= 4800x4800 pixels) vous aurez besoin de  plus:
pour codage d’objet basique:     5000 KB
table de donnée interne map:     1800 KB
table de donnée LOS:   10000 KB
background graphic:   45000 KB
graphique int additionnel:   45000 KB
couche additionnel shadow/trunk: 135000 KB
graphique OVM et MMM:     1500 KB
affectation de50 entrée roof:     7800 KB

-----------------------
251100 KB

Pour une map CCM-Big vous aurez besoin approximativement de 500 - 1040 MB RAM! Gardez
ceci en mémoire quand vous créez et éditez des cartes très larges. Servez vous de mon outil
CC2Tools (Mac & PC) pour couper coller les maps si vous avez des problèmes lies a la RAM. La
mémoire en exedant n’est pas pris en compte par 5CC et le crash du programme peut vous faire
perdre toutes vos données! Faites des back up de votre travail régulièrement! Et comme avec tous
les programmes de moddage: vous utilisez 5CC à vos risques!
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Introduction

5CC sert pour modifier les données des cartes de la série des jeux Close-Combat, de CC2 a la
dernière version de CCM. "Close Combat - A Bridge Too Far" (en abrégé CC2, ABTF), CC2-
ABTF a été le second jeu de la série des Close-Combat réalisé par Atomic et diffuse par Microsoft à
la communauté Mac- et PC- en 1997. CC2 a été le dernier jeu de la série produit et développé pour
la plateforme MacOS. Le jeu fut alors repris et continué par SSI, UbiSoft et développé uniquement
sur PC (depuis CC3, CC4, CC5, CCM, The Road to Baghdad réalise en janvier 2004, abréviation:
RtB, CCM v4 réalisé par l’ USMC a l’été 2005 et, actuellement en développement CCMRAFReg
prévu fin février 2006). La dernière diffusion publique était Close-Combat Marines 3.1 publiée fin
2004.

Depuis 1997 beaucoup de personnes ont travaillé à percer les secrets de la réalisation des cartes
pour  Close Combat. Tous les jeux de la série gèrent les données (structure et graphique) dans
differents fichiers. Leurs formats diffèrent légèrement entre CC2 et les autres, aussi leurs noms et
localisations sont un peu différentes. En premier vous devez connaître ce qui est stocké et a quel
format de fichier il correspond:

- map data file: contient la description numérique de la taille de la map et sa structure de
terrain (type de terrain et altitude). A partir de CC3 on y trouve aussi leurs noms et d ‘
autres informations (type de terrain général, changement des couleurs dans l interface
utilisateur). Le format de ce fichier est en  texte ASCII, avec colonnes sépares TAB et
des lignes délimitées CR pour CC2 et respectivement CR+Clpour CC3 et +.

- map los file (LOS): contient les informations  de la ligne de visée et de tir de la map. Le
format est identique pour toute la série des CC.

- background graphics file (BGM): contient le dessin en entier de la map au format RGB non
compressé 16 bit- similaire au format graphique TARGA. C’est la partie de la carte sur
laquelle vous etes en train de jouer : le champ de bataille quoi !

- overview graphics file (OVM): c’est la carte que vous voyez et ou vous vous trouver lors de
la phase de déploiement avant de commencer le combat ! Elle est sous le même format
que le fichier BGM. Il semble aussi que le jeu utilise ce fichier lorsque vous utilisez le
zoom durant une phase de bataille.

- monitoring graphics file (MMM): c’est la minimap!en bas a gauche de votre écran et est
aussi au même format que le fichier BGM. Le jeu utilise ce fichier comme moniteur pour
vous permettre de localiser le lieu du combat par rapport a la carte entière et a  une icône
durant la  phase de sélection de map.

- roof file (RFM): contient les données des maps internes et externes avec les informations de
coordinations entre ces 2 cartes. La vue intérieure passe par-dessus le BGM quand un
soldat entre dans un bâtiment ou une construction, et la vue extérieure passe par dessus
le BGM quand tous les soldats ont quitté un bâtiment pendant le combat.

- bridge file: contient les graphiques des ponts et en addition ceux du pont réparé (Bailey
Bridge). Ce fichier est uniquement disponible pour CC2. Pendant le jeu le pont de votre
map peut être détruit par les forces de l Axe. CC2 le fait en utilisant une explosion
massive, en plaçant des trous d’obus par dessus le graphisme du pont. Quand le jeu
continu, certains ou tous ces trous d’obus peuvent disparaître, parce que le déploiement
de ces trous d’obus est limite dans CC2. Aussi les concepteurs eurent recours a un
graphique supplémentaire pour rendre les effets destructeurs des obus visibles pendant la
bataille. Le graphique du pont réparé n’apparaîtra par-dessus le BGM que lorsque le
XXX Corps atteindra ce pont en mode Opération/Campagne. Ce type de fichier est très
proche de celui du fichier roof de CC2.
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- BTD file/Scenario file: ce fichier contient les informations des VLs (victory locations),
positions des forces et points d’entrées de la carte. Ce fichier ne peut être éditer par 5CC.

Les fichiers graphiques de CC2 Macintosh/Motorola byte demande BIG Endian, les fichiers
graphiques de CC3 et de la suite des Close-Combat sur Intel byte demande LITTLE Endian. Hormis
pour les fichiers roof leurs formats sont strictement identiques. Le fichier roof de CC3 est un peu
plus complexe que celui de CC2. Mais les écarts entre les deux ne sont pas si grand pour empêcher
des concepteurs comme Gerry Shaw "Tin Tin", Cpl_Filth, Chris Ellens (et en dernier moi) pour
créer des éditeurs pour toute la série des CloseCombat. La table suivante montre les différences:

CC2 CC3 et +
Dossier  des datas map ../Data/Maps ../Maps
Dossier LOS ../Data/Maps ../Maps
Dossier graphique ../Graphics/Maps ../Maps
nom des data map Map### *.txt
Format des datas map ASCII,

TAB-seperated,
CR-delimited lines

ASCII,
TAB-seperated,
CR+LF-delimited lines

nom des LOS Map###.los *.los
Nom des BGM BGMap### *.bgm
Nom des OVM OVMap### *.ovm
Nom des MMM MMMap### *.mmm
Nom des RFM Roof### *.rfm
nom des graphiques des
ponts

Bridg### Non disponible

Taille d octet graphique BIG Endian LITTLE Endian

Petit guide de codage de carte

Ce programme a été crée pour générer/manipuler les graphiques. Réalisez votre carte avec votre
programme graphique habituelle. Rappelez vous que tous les graphismes  de CC sont au format 16-
bit! Dans le passé le format TARGA était utilisé "de facto" en standard pour l enregistrement des
graphismes a importer par les outils de manipulation des fichiers CC.  5CC suis cette règle. Il
importe les cartes utilisées par le jeu au format 16-bit TARGA non compressé. Dans certain cas il
est aussi capable de le faire dans un autre format graphique:

- via the clipboard: 16-bit ou mieux,
- sur PC: cela dépend de votre système d exploitation, 5CC importerait les BMP,
- sur MAC: cela depand de la version de votre OS, 5CC peut importer un fichier PNG (10.4

ou plus) et peut être aussi le format PICT (MacOS 8.5 – 9.2).
- le drag and drop des graphiques n est pas supporté!
- Quand vous importez un fichier graphique externe, 5CC le convertira automatiquement en

16-bit (c’est la raison pour la quel l’importation des images prend autant de temps,en
calculant chaque pixel).

L’exportation des graphiques dépend aussi de votre OS. Toujours au minimum en format  16-bit
TARGA non compressé.

Avant de commencer vous devez savoir ce qu est réellement une "CC map". Une "CC map" est un
rectangle de taille limité. Cette limitation change selon la version du jeu:
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Version Taille max. de la map...
...en pixel ...en deployment

tiles
...en elevation tiles

CC2 (MAC & PC) 2280x2280 19x19 57x57
CC3 2880x2880 24x24 72x72
CC4 3000x30001 25x25 75x75
CC5 3840x38402 32x32 96x96
RtB 4800x4800 40x40 120x120
CCM (standard map) 4800x4800 40x40 120x120
CCM (BIG map) 19200x4800 160x40 480x120

Pour le déploiement des unités et la progression de la partie la map est divisée en carré ou case
(tiles). Ces tiles s’appellent "Mega-Tiles"dans CC2. Chaque Mega-Tile a une taille de 120x120
pixels. Parce que ces cases sont utilisées pour définir la zone de déploiement au début du combat,
nous les nommons simplement "deployment tiles". Les fichiers LOS (contenant les données sur les
lignes de visées) utilisent le même principe. Un "LOS tile" est identique à un "deployment tile". Si
vous connaissez la taille de la map en "deployment tiles", vous pouvez calculez la taille de votre
fichier graphique background BGM (et vice versa).

Le fichier data des maps décrit le type de terrain et son élévation en petits carrés ou cases (tiles).
Chaque ligne contient tellement de données qu’elles sont numérotées séquentiellement (à partir de
0). Chaque ligne se compose de 16 colonnes pour les datas de terrain et de 16 colonnes sur le
codage en élévation (dans le cas de  CC2: seulement une seule colonne  pour l altitude). CC2
n’utilise qu une seule colonne pour l’élévation, alors nous l’appelons "elevation tile". Cette
"elevation tile" a une taille de 40x40 pixels. Elle est divisée en 16 plus petites cases"terrain tiles" de
dimension 10x10 pixels. Les "terrain tiles"à l’intérieur de chaque "elevation tile" sont décomptés de
0 à 15, en partant du bord haut gauche vers le bord haut droit et du sommet  vers la basse.

Il en est de même pour la séquence des "elevation tile" sauf que leurs numérotations vont de gauche
à droite et de haut en bas sans respecter d’ordre de déploiement. Si vous désirez éditer les données
de terrain ou d’élévation, vous devez savoir ou le faire: quel case d’élévation correspond a la case
terrain. Pour le combat et pour rester logique vous devez aussi connaître la position de cette case
dans la grille de déploiement.

Parce que les "elevation tile" sont numérotées séquentiellement a partir de 0 (maximum - 1), je
pense que la taille maximale d’une map que CC peut intégrer a une valeur de 65535. Mais le jeu
actuel que vous modifiez peu avoir une carte avec des limites plus petites. Dans certain cas non
seulement la taille de la map peut être limitée mais aussi les données des fichiers roof  et/ou "trees".
Dans ce cas vous risquez un disfonctionnement du jeu avec votre map, et vous serez forcé de
changer de carte: pour cette raison j ai conçu et diffusé un logiciel (pour Mac & PC) pour
réduire/étirer/convertir/orienter/joindre les maps: CC2Tools.exe / CloseCombat2Tools.

Apres ces bases techniques commençons la tactique du map making. Prenez les guides sur la
réalisation des cartes et les FAQs publiés par la communauté CC pour les concepts plus spécifiques:

                                                  
1 David_Michael rapporte en 2006 une map max. pour CC4 de 2880x2880 pixels!
2 Un post en fevrier 2006 sur le forum de CSO rapporte une map 3840x3840 pixels pour CC5.
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Map size
- Décidez si vous faites une map pour une version de CC ou pour toutes,
- Choisissez sa taille (en pixels: forcement un multiple de 120 pixels),
- Rappelez vous que le soleil éclaire du bord haut gauche au bas droit,
- Orientation des map: les map deCC2 sont orientées horizontalement, celles de CC5 sont

souvent verticales, les cartes pour RtB et CCM-standard doivent avoir une taille de
4800x4800 pixels.

- Rappelez vous cette échelle: 5 pixels pour un mètre. Mais les derniers jeux de CC
montrent souvent des détails plus grands sur les cartes.

Realisation de votre carte extérieure
- Faites votre 1ere cartes avec votre logiciel graphique habituel. N’oubliez pas de faire

souvent des sauvegardes de votre travail.
- Faites votre carte (background) de base sans ombres ni  buildings.
- Puis rajoutez les buildings avec leurs ombres. Gardez cette étape de votre réalisation!
- A partir de CC3 vous devez faire aussi les ombres des arbres, Pour CC2 vous pouvez ne

pas le faire car les ombres des arbres sont dans le fichier "Terrain".

Réalisation de votre carte intérieure avec vos constructions
- Si vous avez plus d un building sur la map, je recommande de dupliquer votre BGM

final,
- Peignez les vues intérieures de vos bâtiments.

Vous pouvez aussi faire les graphiques des  autres fichiers OVM et MMM, si vous le désirez.
Pour  CC2 seulement: si besoin, créez votre graphique de pont détruit et bien évidement celui du
pont réparé.

Avec 5CC vous pourrez alors
- Réaliser le codage de la map avec les datas par défaut,
- importez la map comme fichier BGM (et si possible séparez les 2 couches contenant les

vues intérieures, ombres des arbres et troncs aussi),
- éditer/définir les valeurs de codage du terrain (vous verrez toujours votre BGM en arrière

plan),
- éditer/définir l’élévation (en incluant l’élévation generee a partir d une image  greyscale

importée),
- definir vos roofs,
- pour CC2: définir la zone de destruction des ponts et nécessairement le codage du pont

répare et de son secteur,
- générer les LOS, avec la possibilité de les éditer (les LOS seront calcules en respectant le

codage en élévation,le type de terrain,obstacles et altitude),
- générer les fichiers graphique OVM et MMM,
- sauvegardez votre travail dans des fichiers correspondant aux règles des noms et dossiers

de votre jeu Close Combat.

Et bien sur vous modifiez le codage des datas en éditant les données de cartes déjà existantes ou les
votres. Rappelez vous: sauvegardez votre travail souvent.Quand vous chargez une map, 5CC
détectera le format de codage du fichier: les données de CC2 seront identifiées facilement par leurs
en-tête différents (2 octets d’en-tête).Les dats LOS ont toujours le même format (heureusement!).
Les BGM seront reconnus comme données CC2 si elles sont chargées en même temps avec les
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datas map CC2 ou si l’en-tête est CC2-BGMap### séquence: 4D 41 50 49 00 02 00 00 hex. Les
Roofs (et ponts) sont reconnus facilement par leur unique en-tête. Les OVM et MMM n’ont pas
d’en-tête montrant leur version. Ils seront interprètes comme fichier CC2 si ils sont chargés en
même temps que et avec un fichier CC2-BGMap###. Cela peut être la cause d’un
disfonctionnement du programme si vous prenez un fichier CC5 *.mmm avec un fichier CC2 map.
Ne le faites pas! Ne mélangez pas les datas CC2 avec un fichier issu d’une autre version de Close
Combat. Servez vous pour cela de mon programme (comme décrit plus haut) pour convertir les
cartes entres les différentes versions du jeu.

La barre de menu

Barre de menu "File"

 "File>New..." pour coder les datas d une map. La fenêtre suivante apparaîtra:

Choisissez le type de codage à réaliser CC2 ou une autre de la série CC3, CC4, CC5, RtB, CCM. Si
vous prenez "standard CCM / RtB", la map sera ouverte en 40x40 "deployment tiles". Idem pour
"big CCM map", le resultat sera largeur / hauteur 160x40 "deployment tiles". Pour tous les autres
types de cartes vous choisissez la taille qu il vous faut, calculez en deployment tiles (les
"deployment tiles" sont des carrés de 120x120 pixel). Quand vous prenez "Close Combat 2", vous
pouvez renommer votre map en changeant son numéro (entre 100 et 999). Ce numéro servira a le
description de la map lorsque vous l enregistrerez.

Vous pouvez charger une map existante par les menus "File>Open..." ou "File>Open recent". 5CC
garde en mémoire les 16 derniers fichiers ouverts. La boite de dialogue et son format (qualité
graphique) dépendra de votre syteme d exploitation et de votre environnement logiciel. 5CC détecte
les dats de votre map en identifiant les 2 octet d en-tête des versions. Si l identifiant de CC2 est
trouvé, 5CC cherchera le dossier graphique en utilisant le chemin "../../Graphics/Maps". Pour les
maps CC3 (ou plus), 5CC cherchera le graphique dans le dossier ou réside les données. 5CC obéis
strictement a la convention des noms de CC: Si le graphique se nomment "Map100", alors 5CC
cherchera les autres données dans "BGMap100". Et pour CC3 (ou plus) il changera uniquement
l’extension (exemple: "Andorra.txt" fichier data, "Andorra.bgm" comme fichier BGM).

Si un fichier "background graphics" ne peut être trouvé, 5CC vous demandera de spécifier le
chemin valide. Ce doit être un fichier CC bien sur. Les fichiers sous format graphique (TARGA,
BMP, ...) ne peuvent pas être charge de cette façon. Apres avoir charge ce fichier 5CC fera de
même avec les datas type OVM et MMM. Si ces fichiers ne sont pas trouvés, 5CC les créera lui-
même (laissez le temps au processeur de le faire). Puis il cherchera les datas roof et pour CC2
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seulement les datas pont ("bridge"). Les datas LOS ne seront pas chargées automatiquement sauf si
vous changer les préférences par le menu "Preferences window".

Pour sauvegarder passez par le menu "File>Save". 5CC prendra par défaut le chemin du dossier ou
votre carte a été ouverte. Il réécrira par-dessus les datas existantes sans vous prévenir. Mais il n
enregistrera que les données modifiées. Exemple: Chargez une map via le menu "File>Open..." sans
OVM et MMM trouvés, alors à la commande "File>Save" enregistrera les OVM et MMM crées
dans le dossier correspondent au chemin utilise au chargement de votre map.

Vous pouvez vérifier dans "Map properties window" quelles graphique/datas ont été changées.

Sauvegardez votre map en entier sous un nouveau nom ou un autre dossier, en utilisant le menu
"File>Save as...". Tous les graphiques et datas actuellement chargés seront écrit sur votre disque
dur, même s il n y a pas de changement. Cas spécial  CC2: si le chemin valide "../Data/Maps/" and
"../Graphics/Maps/" n’est pas trouvé, 5CC stockera ensemble les fichiers dans le dossier spécifie
plus haut. Assurez vous que vous utilisez le bon chemin pour les fichier datas des cartes CC2:
"Map###" (ou # est un chiffre simple), Sinon la sauvegarde échouera!

Les menus "File>Save" et "File>Save as..." analyserons les datas de terrain et d élévation pour les
valeurs négatives. Si il y a aussi ces valeurs, 5CC vous avertira. Une map contenant aussi des
valeurs négatives ne fonctionnera pas. Mais vous pouvez enregistrer votre travail pour corriger ces
valeurs plus tard. Utilisez le menu "File>Scan for negative values" pour rechercher les valeurs
négatives sans sauvegarder les datas de votre map.

Le menu "File>Close" fermera la fenêtre active. Pour PC seulement: si la fenêtre "editing
window"est la seule ouverte,  5CC fermera.

Dans tous les autres cas utilisez le menu "File>Quit" (MacOS-X: "5CC>Quit")  pour terminer le
programme. Si vous avez des fichiers non sauvegardées, 5CC vous le dira avant de quitter.

Le menu "File>Generate LOS" lancera une fenêtre pour générer les datas LOS de la map en cours.
Par le menu "Preferences window" vous pouvez déterminer la manière de calcul des LOS par
défaut. Et aussi définir les restrictions de distance au même valeur que celle sélectionnées dans
"LOS actions window". 5CC l enregistrera dans un dossier préférences "5CC.ini".

Le sous menu "File>Import..." donne la possibilité d importer un seul fichier CC files ou graphique
extérieur pour la map déjà chargée. Exemple: vous avez seulement le fichier data map de prêt, mais
pas les graphiques. Créez une nouvelle map a la taille voulu par le menu "File>New..." et charge les
données existantes via le menu "File>Import...>Import Map### / TXT file...". Le menu
"File>Import...>Import Map### / TXT file..." créera une carte complète de la map en RAM en
écrasant toutes les données de map existante (data, graphics, roofs, bridges). En d autres termes: le
menu "File>Import...>Import Map### / TXT file..." est similaire au menu "File>Open..." a part le
fait que seul le fichier data (Map### / *.txt) est charge.

 Tous les autres menus "File>Import..."importeront les datas graphiques au données déjà chargées
(data et graphique). Dans ce cas l’importation peut être de format différent (CC2 ou CC3 et les
autres) que celle du fichier data en cours: vous pouvez créer une map CC2 avec 5CC et alors
importer un fichier BGM CC4 pour être utilisé comme graphique de fond.  La seule règle a tenir est
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d importer un graphique a la même taille que celui en utilisation. Melanger les fichier BGM d une
map CC2 avec CC3-ou-+  requière de charger les OVM et/ou MMM séparément, et vice versa.3

5CC charge aussi les fichiers graphiques externes. Importer des fichiers 16-bit TARGA est un menu
séparé. Ce dessin doit être orienté de gauche à droite. Les fichiers TARGAS orientes de droite a
gauche ne le seront pas. 5CC peut importer des dessins TARGAS orientés du haut vers le bas et du
bas vers le haut si leurs en-têtes sont correctes. Les autres fonctions d importations dépendent de
votre système d exploitation (et peuvent être améliores si vous avez le logiciel QuickTime® installé
sur votre machine). Au minimum au format BMP sur  PCs et au format PNG- (peut être en JPEG-)
sous MacOS-X 10.4. 5CC convertira le fichier graphique importe automatiquement au format  16
bit.

Mais attention: importer des données (datas ou dessin) ecrasera celles existantes déjà pressentes en
RAM. Exemple: si vous importez un fichier roof, les définitions du roof en cours seront perdus.

Pour les cas particuliers le sous menu "File>Add...". Le menu "File>Add...>Add Roof file..."
importera les nouvelles defintions roof  sans ecraser les données de la RAM. Ce sous menu a aussi
été fait pour importer le dessin extérieur pour la création du dessin intérieur en seconde couche.
Cette seconde couche graphique est destinée a la réalisation de la vue interne de vos constructions.
Elle sera utilisée pour créer le roof final, mais  ce n est pas un fichier CC ne sera pas sauvegarde par
le menu "File>Save" ou "File>Save as...".

Dans le sous menu "File>Add..." vous pouvez aussi importer les graphiques des ombres des arbres
et des troncs. Et vous trouverez ici aussi la commande pour importer une image de l echelle de gris
pour définir l élévation de la map. Quand vous le faite (de faite une image RGB 16-bit avec
différent gris estompe) la couleur noir (= RGB (0, 0,0)) représente élévation = 0. La couleur blanche
(= RGB (255, 255,255)) donnera une élévation = 255. 5CC calcule la couleur moyenne de chaque
carres (pixel 10x10) pour crée l élévation des "terrain tile" (Pour CC2: 5CC calculera le couleur
moyenne de tous les pixels de 40x40 pour obtenir l altitude de l "elevation tile").

Autre sous menu spécial: "File>Generate...". Ici vous générer les  fichiers OVM et MMM issu du
fichier BGM toujours en RAM. Ces fichiers ne seront enregistres que par le menu "File>Save" ou
"File>Save as...". La command "File>Generate...> interior background picture from BGM and
Roof" combinera le fichier BGM en RAM avec les vues internes de votre ROOF en RAM. 5CC
prendra seulement les pixels non-blanc du roof intérieur. Et il respectera la valeur de la"Largeur
Visuel" de CC3-ou +. Avec cette commande vous pouvez créer le graphique interne avec les
intérieur de vos buildings’ peint sur cette seconde couche dont je parle plus haut. Pour sauvegarder
ce graphique vous pouvez seulement utiliser les menus "File>Export...>interior background
picture..." ou "File>Export...>interior background as 16-bit TARGA..." qui sera décrit dans le
chapitre suivant.

Le sous menu "File>Export..." vous autorise a exporter les datas / graphics de la même manière que
pour les importations ou le sous menu add. Vous exportez:

- les fichiers datas map et LOS,
- l image d arrière plan comme BGM ou dessin,
- l image d arrière plan combine avec la couche d ombres et les troncs d arbres comme BGM

ou fichier image,
- la couche d ombres arbres et troncs comme fichier image,

                                                  
3
A l importation d un BGM, le fenêtre "Coordinates" n adaptera pas le graphique du moniteur. Utiliser les menus

"File>Generate>OVM from BGM" et "File>Generate>MMM from OVM" pour obtenir la map du moniteur dans  cette
fenêtre après l importation du BGM.
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- le roof extérieur ou intérieur passé par dessus le fichier de fond comme fichier image,
- le roof extérieur ou intérieur passé par dessus une image blanche comme fichier image,
- les données d élévation transférer dans une image a base de gris (échelle de niveau),
- un "screenshot" du graphique de la map avec les actuels  grilles visibles / numérotation /

surbrillances / bordures peintent.
- Les images OVM et MMM comme OVM/MMM ou fichier image,
- les roofs comme fichier roof,
- l image CC2 bridge comme Bridg### file,
- et vous pouvez créer ici un fichier roof vide pour CC5/RtB/CCM.

Quand vous exportez les graphiques CC comme graphique externe vous pouvez choisir soit le
format 16-bit TARGA soit un format offert par votre environnement logiciel. Cette option dépend
de votre système d exploitation. Sur PC l export peut être possible en BMP, sur Mac vous aurez les
formats compatibles avec QuickTime® s il est installé sur votre ordinateur. L image plus haut
montre les possibilités sous MacOS-X 10.4.

Le menu "File>Preferences..." (Sur Mac: "5CC>Preferences...") affichera une fenêtre "Preferences
window". Ici vous pourrez sélectionner les réglages par défaut de 5CC. Tous ces réglages (et plus
encore) sont enregistrer dans le fichier "5CC.ini" quand vous quitter 5CC. Ce fichier est
automatiquement charge au lancement de 5CC. La localisation de ce fichier dépend de votre Os.
Vous pourrez le trouver en switchant sur le bouton "About" dans le fenêtre des "Preferences
window".

Fenêtre "Preferences"

Parameters generaux:
- enable (activez) "Undo command" pour tous les outils d éditons terrain et élévation.
- enable (activez) LiveScroll: activez le si vous avez un cpu rapide pour voir le scrolling en

temps réel.
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- Enable (activez) le double tampon graphique pour éviter le screen flickering. Sur  enabled la
vitesse du graphisme dépend seulement de la puissance de votre CPU.

- use faster renderer: seulement nécessaire sur MacOS-X: utilisez le vieux (mais plus rapide)
moteur QuickDraw au lieu du nouveau moteur Quartz.

- Sélectionnez quelle fenêtre se verra immédiatement au lancement du programme. Pour PC la
fenêtre d édition principale sera toujours présente.

Parametre des Map:
- La valeur par défaut du terrain se chargera  a la création d une nouvelle map. Cette valeur

sera utilisée sur toute la map et pour toutes les versions de CC. Avec une portée possible de
"-1" (représentant "une valeur non définie" = "valeur illégale") a "254".

- La valeur par défaut de l élévation se chargera a la création d une map pour la map entiere et
pour toutes les versions de CC.

- prefer CC2 editing: sur active le popup menu, "Create new map dialog window" montrera
une "CC2 map" par défaut a son premier lancement. Et toutes les boites de dialogue pour
sauvegarder/ouvrir vous demanderons d aller chercher votre fichier.

- enable toujours essayer de charger le fichier LOS au chargement d une map avec la
commande "File>Open...".

- enable toujours créer les OVM et MMM au chargement d un fichier BGM (via
"File>Open..." ou "File>Import...“ sous-menu) si les fichiers OVM et MMM ne sont pas
trouves.

- enable automatiquement "Coordinates window“ sur ON quand un map est crée ou chargée.
- définissez ici ce qui l arrivera quand la commande "File>Generate LOS" est en utilisation.

Vous pouvez choisir l une des trois méthodes de calcul  des LOS. Et vous pouvez les
combinera avec des restrictions en distance sélectionnes dans le menu "LOS actions
window" (voir page 26 du manuel)

Select "Terrain Elements File":
Choisissez un des 9 fichiers d éléments de terrain pour utiliser/éditer les datas de terrain (stocke
dans le fichier data  de la map). 5CC reconnaîtra les fichiers originels de CC2 et CC3 comme
entrées valides. Depuis v1.03 5CC a besoin d une colonne additionnel dans ce fichier pour le
groupage des éléments de terrain par catégories. Si cette colonne est manquante, vous ne verrez qu
une seul catégorie (sans en-tête) dans la fenêtre "Terrain"de 5CC. En  addition avec ces deux
formats 5CC peut utiliser son propre fichier de "terrain element":

- ASCII simple, TAB-seperated columns, le délimiteur de fin de ligne n importe pas(CR
ou CR+LF),

- la première ligne doit contenir un en-tête de trois octets"5CC",
- le fichier doit avoir 5 colonnes: la 1ere contient le nom "element name", suivi de la

colonne pour le numéro "terrain class number", "terrain height", "terrain level" (pour le
multis-superposage des buildings) et "terrain category".

- La ligne d en-tête peut être suivi par un commentaire,
- Le début des données doit être indiquée par une ligne contenant "&" a son début,
- La fin des données doit être indiquée par une ligne contenant un "#" a sa fin.

Ce format est similaire a celui  utilise pour les fichiers "element" de CC2 et CC3 excepte pour vider
les colonnes non utilisées. Le tableau  montre les différences (colonnes comptées à partir de 0):
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Terrain
Elements
File
version

Header ID
(string)

Element
name is
located in
column

Terrain
class
number is
located in
column

Terrain
height is
located in
column

Terrain
buildings
level is
located in
column

Terrain
category

CC2 46 0 1 2 39 42
CC3 14 0 1 2 42 47
5CC 5CC 0 1 2 3 4

La catégorie de terrain dans la dernière colonne peut être de n importe quelle type de caractères.
Vous pouvez utiliser autant de catégorie que vous désirez. Les deux catégories réservées "Négative
value" et "Unknown value" seront generees par 5CC lors du lancement pour le stockage des
éléments de terrain non définis dans l actuel fichier "Terrain Elements". Si vous n aimez pas les
noms pré-definis des catégories, vous étés libre de les changer dans "Terrain Element Files". Les
éléments de terrain avec un nom identique seront regroupes ensemble et toujours dans le fenêtre
"Terrain".

Quand vous avez mis à jour le fichier extérieur "Terrain Elements" tandis que 5CC fonctionne, vous
pouvez recharger ce fichier en appuyant sur le bouton "Reload". 5CC contient des fichiers prêt a l
emploie de "terrain element" pour CC4, CC5, RtB et CCM en format CC3, aussi. Ces fichiers ont
été générés par QClone l’outil fait par Sgt_Wilson (modifie manuellement).

Dans cette section préférence vous pouvez aussi définir la taille par défaut du fichier TEXTS de la
fenêtres "Terrain". Une exception pourtant: pour la version PC vous ne pouvez pas utiliser un
caractère plus de moins de 10pt. Quand vous sélectionnez 9pt ou moins vous obtiendrez seulement
des lignes de texte inférieures.

Depuis la version 1.04 de 5CC vous pouvez activer la fonction "non défini" = "illégal" pour les
valeur des éléments de  terrain dans les actuelles tables sélectionnées en RAM. En activation, "-1"
sera ajouté a la table des éléments de terrain en  RAM automatiquement a chaque chargement d un
fichier de votre DD sans changer ces fichiers eux-mêmes sur le DD4. Une autre checkbox dans cette
section peut être activé pour que cette valeur illégale soit écrite sur la map par l outil d édition de
terrain.

Couches:
Quand vous mettez une ombre d’arbre (patch element), vous
pouvez vouloir éviter d’avoir les ombres entassées les unes sur
les autres. Dans cette section préférences vous pouvez
sélectionner si vous permettez  de lier/superposer les ombres ou
si vous voulez l’éviter.

Pour une utilisation optimale de l export de la couche graphique des ombres dans votre logiciel de
dessin favori je recommande de mètre l opacité par défaut a to 100% et de réduire l opacité de l
ombre plus tard avec votre logiciel de dessin. Une opacité de 55% - 45% est recommandée
seulement si vous utilisez 5CC pour générer le nouveau BGM compose des couches d ombre et
BGM.

                                                  
4 you can establish terrain element table files containing negative class numbers, in this case 5CC will treat them as
regular values (perhaps necessary for future expansions of CC). When doing so, you should disable the  "add '-1' to the
element table when it is loaded".
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Et vous pouvez poser ici la position de la fenêtre montrant la couche visible. Cette fenêtre est
habituellement de seulement 20 pixels de haut. Pour les MacOS-X, 5CC affiche cela comme une
fenêtre flottante en haut à droite de la fenêtre d’édition principale. Vous pouvez le placement
horizontal interne compte en pixels a partir du cote droit de cette fenêtre. La version PC de 5CC
placera la fenêtre "Visible layers" comme une fenêtre normale au sommet de la fenêtre principale d
édition. Dans ce cas le placement horizontal est compte en pixels du bord gauche de cette fenêtre.
Vous pouvez aussi changer ce placement vertical (les valeurs négatives sont permises) et de  le
limiter dans la fenêtre d édition en haut ou et en fond. Et il est aussi possible limiter la fenêtre
"Visible layers" aux autres fenêtres (coordinates, tools, terrain ou a aucune).

Couleurs:
Vous pouvez modifier la couleur utilisée 5CC dans le menu "Editor windsurf". Tout les paramètres
sont groupées ensembles par thème de couleur. Le nombre de ces thèmes est limité à 99. En
pressant le bouton "+" vous ajouterez un thème de couleur. Un double clic sur le mon du thème
vous permettra de le renommer. Pour vérifier ces changement appuyez sur le bouton "Apply color
changes". Cliquer sur le rectangle coloré vous permettra de changer la couleur spécifiée. Mais vous
devez vérifier encore le changement en pressant le bouton "Apply color changes" button. Vous
pouvez choisir la couleur du thème qui sera utilise par défaut dans la fenêtre "Editing window" en
passant par le menu "Colors". Deux thèmes de couleur sont fixes par défaut et ne peuvent être
effaces, Mais vous pouvez changer leurs couleurs.

Largeur OVM et MMM:
Entrez ici quelle largeur d image 5CC doit utiliser comme limite maximum a la création d un OVM
à partir d un BGM graphiques et d un MMM a partir d un OVM graphiques. Si la hauteur est plus
grande que la largeur, ces valeurs seront prises comme limite pour le calcul de la hauteur. Le bouton
"Restore defaults" vous fera revenir aux valeurs par défaut originels. Les valeurs maximums
trouvées dans les fichiers CC sont listées dans le tableau dessous:

CC version Max. OVM size in pixel Max. MMM size in pixel
CC2 1142x646 144x144
CC3 1024x716 160x160
CC4 1024x716 160x160
CC5 1024x716 160x160
RtB / CCM standard map 716x716 160x160
CCM big map 1024x256 640x160

Keys:
Entrez ici les raccourcis clavier pour les outils disponibles dans la fenêtre "Tools". The setting is
case sensitive. Charactere special (comme TAB, spacebar ...) ne sont pas supportes. Les chiffres
"0".."9" sont réserves pour les valeurs de l élévation.

Barre de menu "Edit"

"Edit>Undo" est disponible pour les situations suivantes:
- Vous pouvez inversez l effacement d un roof complet (cela veut dire: quand vous avez utilise

"roof erase tool" ou la commande "Edit>Clear" sur le roof en surbrillance montrant la vue
extérieure),

- Vous pouvez effacer l écrasement de tous les roof (quand vous avez utilise la commande
"Edit>Clear all Roofs"),
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- Et vous pouvez effacer les changements des datas et des graphiques quand vous avez utilise le
menu "tree shadow patch tool".

- toutes les actions des autres outils d édition de terrain et d élévation peuvent être annule si
"Undo" est active dans la fenêtre "Preferences" section "General". Dans ce cas les datas de la
carte entière seront recharge via la mémoire tampon en utilisant cette commande. L utilisation
des ressources Ram est importante a l édition des cartes larges. C est la raison pour la quel vous
pouvez désactiver "undo" ici.

Les commandes "Edit>Cut", "Edit>Copy" et "Edit>Paste" sont disponibles quand une vue roof
extérieure ou intérieure est sélectionnée en surbrillance. "Edit>Copy" copiera la vue du roof
sélectionnée (ou l image visible CC2 bridge) vers le presse papier. "Edit>Paste" passera du presse
papier (si c est une image) a la vue roof en surbrillance seulement si les taille correspondent
exactement entre elles. Idem pour une image CC2 bridge. "Edit>Cut" nettoiera la vue  du roof
intérieur (un rectangle noir vous l indiquera) seulement, si vous avez sélectionné "interior roof
view" sur ON. Si vous avez "exterior roof view" sur ON, alors la commande "Edit>Cut" effacera le
roof en entier sans avertissement. Alors si vous voulez supprimer seulement le roof extérieur,
utilisez le menu "Edit>Paste"  et coller un quelconque graphique dedans.

Cas CC2 spécial: si vous étés en mode d édition des datas du pont réparé, la commande "Edit>Cut"
désactivera l activation  de l élévation selectionneé sur le secteur de donnée du pont réparé.

Le menu "Edit>Define as Roof" définira le secteur de carte choisi (sélectionné par l outil rectangle
ou par l outil polygone) comme entrée roof, sélectionner les entrées des coordonnées roof ( et
vertices dans le cas de CC3 et +) et couper une zone du fond(background). Ce système sera utilise
pour le vue roof externe et sera aussi collé automatiquement au presse papier (technique introduite
par Chris Ellen dans CCEdit). Vous pourrez utiliser l’image du presse papier dans votre logiciel
graphique préféré pour peindre la vue intérieure par dessus, la recopier dans le presse papier,
revenir à 5CC, sélectionner "interior roof view" sur ON et coller la vue intérieure que vous venez de
modifier dans le roof en surbrillance. Ceci a été fait pour vous éviter de penser à la correspondance
des tailles de fichier image. Si vous avez ajouté une vue de fond avec vos intérieurs de bâtiments
peint sur la deuxième couche (via le menu "File>Add...>Add interior background picture..."), l
extraction de cette couche sera transfère a la vue roof intérieure quand le menu "Edit>Define as
Roof" sera utilisé. Une technique introduite par Cpl_Filth’ dans le programme Groof. Recommandé
pour les map avec plus d un roofs ou avec des roofs  se superposant.

Le sous menu "Edit>Update all Roof graphics“ est destine pour des cas spéciaux. Au cas ou vous
auriez plusieurs définitions roof et décidez alors de retravailler votre image graphique BGM, vous
seriez habituellement oblige de refaire vos datas roofs. Pour éviter ce dur travail utilisez la
commande de cette subdivision pour recharger le graphique tampon de la vue roof extérieur issu du
BGM graphique et / ou du graphique tampon pour la vue roof intérieur de la seconde couche (BGM
graphique avec le vue interne de vos bâtiments peint dessus) sans changer la coordination des
entrées roof !

Le menu "Edit>Clear all Roofs" vous demandera la confirmation d effacer tous les roofs. Cette
commande ne peut être annule par le menu "Edit>Undo". La commande "Edit>Clear all Roofs
outside map" éliminera toutes les entrées  roof qui sont en dehors des bord du cadre de la map.
Cette commande ne peut être annulée!

Le menu "Edit>Select/Edit tree shadow patch..." montrera la fenêtre "Trees", ou l utilisateur peut
éditer (et sélectionner) ces datas graphiques tree et taches.
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Le menu "Roof"

Menu à utilisez pour changer la visibilité des images roof (ou l image de CC2 bridge). Il est
seulement possible de voir la vue du roof extérieur ou intérieur ou de l image du pont détruit ou
répare pour CC2 ou aucun des quatre (alors le BGM sera montré). Usuellement la vue du BGM
sera identique avec le vue "roof exterior view" sur ON. Mais il y a une autre utilisation: durant le
jeu l image extérieur du  roof  passera par-dessus le background pas au début de la map, mais
seulement si un soldat quitte le building. Utilisez cette particularité sur votre création donnant a la
vue roof extérieur une image légèrement différente de celle habituelle dans le BGM (peut être pour
indiquer quel bâtiment a été "visité"). Deux maps utilisent cette particularité: CC2-
ModifiedVeghelMap300 par Mick "xe5" Conmy (pour simuler un passage a gué) et moi CC2-
Settore-L map (pour simuler un champ de mines ravagé).

Changer de vue est possible dans tous les modes d éditions. Vous pouvez voir les intérieurs quand
vous définissez votre terrain (autrement vous ne sauriez pas ou placer une fenêtre ou une porte!). Si
vous étés en mode édition de roof et changez la vue pour celle du pont détruit vous basculerez aussi
au mode d éditons image du pont. Et vice versa: si vous étés en édition de l image du pont et
changer la vue roof extérieur / intérieur, vous basculerez automatiquement en mode édition des roof
edit.

Le sous-menu "Roof>Rectangles or Polygons..." est fait pour le mode d’édition des roofs. Vous
pouvez sélectionner ici quelle type de limite de roof  vous verrez sur l’entrée des roofs définis.

Barre de menu "Actions"

La sous-section "Actions>BGM actions" vous autorisez a effacer le background graphiques /
couches et d ajuster toutes les couches a la taille de la map dans la cas ou vous avez importe un
fichier BGM plus large ou plus petit (après l import d un plus petit BGM les zones non remplies
seront colorer en blanc. Apres  l emition de la commande "Actions>BGM actions>Adjust all layers
to map’s size" les zones non remplies seront en noir).

La commande "Actions>LOS actions..." affichera une fenêtre pour générer le LOS ou éditer une
seule couche LOS avec plus de spécification. Nous en reparlerons a la page 26 du manuel.

La commande "Actions>Data actions..." affichera une fenêtre pour manipuler les datas terrain et
élévation. Les actions disponibles pour l élévation affecterons soient la map entière soient peuvent
être restreinte a une sélection des valeurs d élévation existantes. Trois actions sont possibles:
remplissage de l élévation, augmentation de l élévation (fonctionne comme un élévateur) et
multiplication de l élévation (a utiliser pour augmenter le contraste entre les differents niveau de
gris de l élévation). La multiplication de l élévation doit être entrée dans  le format numérique de
votre région (exemples: pour US/UK: un point pour entrer les valeurs décimales; pour GE/FR: une
virgule pour entrer une valeur décimale) comme montre dans le texte d information de cette fenêtre.

Les actions disponibles pour le terrain peuvent aussi avoir des effets sur la map entière ou avoir un
effet limite a une seule valeur de terrain ou a toutes les valeurs d une catégories. Seul  l’action de
remplissage est disponible. Dans cette fenêtre vous pouvez aussi basculer la protection en écriture
de tous les éléments de terrain’ (on / off / invert).
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Barre de menu "Visibility"

The "Visibilty>Grid..." subsection let you select what kind of grid will be displayed. Because the
"Coordinates window" shows you in which tile (elevation and deployment tile) the mouse pointer is
located, you will not use this feature often I suppose. "Visiblity>Grid...>Grid coordinates show"
might be usefull for boot camp modders, because CC3-or-newer uses for deployment of troops in
boot camp files the elevation tile numbering and for moving these troops an elevation tile
coordinate grid (like CC2). All other commands are intended to bring several additional windows to
front and / or to arrange them.

Barre de menu "Color"

Sélectionnez ici la couleur du thème à utiliser dans la fenêtre "Editing window". C est un menu
dynamique, et son comportement (peut être étrange) dépend de votre système d exploitation (il est
optimise pour un MacOS-X).

Barre de menu "Help"

Quelques textes d’aides supplémentaires sur les basses du" map making" et les limites de 5CC.
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Les Fenêtres

Fenêtre "Editing"

(L’image montre la map CC3-Zertorer de Andrew Glenn "Naked Foot" dans  "Editing window". Le dossier de
cette map contient un excellent guide sur le map making pour CC3)

C est la fenêtre ou vous éditerez votre carte. Dans le titre de la fenêtre vous aurez le nom du fichier
data de la map et la taille de celle-ci en "elevation tiles".

A partir des maps de CC3-ou-plus vous pouvez entrer dans la zone inférieure de la fenêtre le nom
de la carte et vous pouvez le style général de la map ainsi que la couleur de votre interface.

Que se passé t il quand vous cliquez avec votre souris sur la zone d édition ? Cela dépend du mode
d édition sélectionnée. La sélection du mode d édition est seulement possible dans le menu "Tools
window".

 Le changement des valeurs de terrain, du codage en élévation ou des rectangles/polygones du roof
doit être fait avec le bouton gauche de la souris. En mode d édition du terrain, vous pouvez utiliser
le bouton droit de la souris (CTRL-clic souris sur Macs) pour faire apparaître un menu montrant les
dix derniers éléments de terrain utilises, les éléments de terrain par défaut, l élément de terrain
directement sous le pointeur de la souris et l élément de terrain actuellement sélectionne. Vous
pouvez changer facilement la valeur d élément de terrain en utilisant ce chemin sans passer a travers
l écran puis la fenêtre "Terrain" et retour (ce sera un bon replacement pour les loupés "terrain eraser
tool").Une fonction similaire est disponible pour l éditons des LOS.

En plus de la souris vous pouvez utiliser le clavier pour entrer l élévation quand vous étés en mode
d’édition d’élévation. Le fonctionnement est identique à CCEdit:vous devez entrer deux code via le
clavier pour changer la sélection terrain/elevation tile’s. Pour entrer une valeur inférieure à 10
pressez "0" et après entrer le chiffre voulu. Entrer une élévation après 99 est possible via la fenêtre
"Tools".
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Fenêtre "Tools"

Cette fenêtre contient une palette d outils. Sélectionner un outil changera le mode d édition dans la
fenêtre "Editing window". Tous les outils ne sont pas disponibles pour CC3-et-+.

Le bouton le plus en haut de la palette affichera la fenêtre "Preferences window" avec la sélection
"Terrain Element File". Si vous cliquez sur le texte "Terrain:" dessous, la palette"Tools window" se
positionnera sur le bord haut gauche de l écran. La fenêtre "Terrain window" se positionnera sur son
coté droit.

Outil edition de terrain:

terrain pointing: par défaut. Cliquez avec cet outil sur la zone d édition "Editing
window" sélectionnera seulement l actuelle élévation, sa positon et le type de terrain.
Spécial pour CC2: en mode édition data pont réparé, cet outil vous laissera activer la
valeur de l élévation de la case pour la zone de pont réparé. Cette case élévations
ajoutera a la fin du fichier data CC2 dans la seconde section. Regardez la map originel
"Map300" et mon texte "CC2Guide-Bridg-files_v6.pdf" disponible sur internet. Pour
désélectionner juste une case vous pouvez seulement vous servir de la commande
"Edit>Clear".
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ajoutera a la fin du fichier data CC2 dans la seconde section. Regardez la map originel
"Map300" et mon texte "CC2Guide-Bridg-files_v6.pdf" disponible sur internet. Pour
désélectionner juste une case vous pouvez seulement vous servir de la commande
"Edit>Clear".
switch to CC2-repaired bridge data editing: seulement pour CC2. En pressant ce
bouton tous les autres outils d édition de terrain feront seulement effet sur les data de la
zone définie du pont réparé. Toutes les autres zones de carte sont passées en arrière avec
un motif colore. Si "repaired bridge data editing" est sur ON, l édition de l elevation n est
pas possible. Seul l édition du terrain est possible.

terrain pencil: un clic sur la case code celle-ci avec la valeur sélectionnée. La taille du
pinceau dépend de la sélection dans le menu "Pen size".

terrain selecting tool: un clic sur la case sélectionnée affect sa valeur comme valeur de
terrain par défaut. Alternativement vous pouvez sélectionner la valeur actuelle du terrain
dans le fenêtre "Terrain window".

terrain rectangle pencil tool: le click and drag remplira les cases terrain par la valeur
sélectionnée du terrain. Cet outil n est pas disponible pour le mode édition des data de
pont réparé CC2.

terrain line tool: dessinera une ligne de  terrain de la 1ere position a la sélection
suivante. La taille de la ligne dépend de la sélection effectuée dans le menu "Pen size".
La première position ressemblera a l outil pinceau "terrain pencil". Désole, il n y a pas de
curseur anime disponible pour voir la progression de la ligne entre la 1ere position et la
2eme. Vous pouvez d abord scroller  pour placer la seconde position pour dessiner des
lignes plus larges que la taille visible de la fenêtre d édition. Cet outil n est pas
disponible pour l édition des datas de pont réparé pour CC2.

terrain brush tool: remplira entièrement les cases d élévation avec la valeur de terrain
actuelle. Si vous voulez voir en premier le placement de la zone pour utilise cet outil je
recommande de mettre  la grille de visibilité des cases d élévation sur "ON". Seulement
disponible en édition des datas du pont réparé pour CC2.

terrain tree shadow patch tool: vous laisse sélectionner l actuelle tache d ombre d arbre
et mets le déplacement de la tache sur "ON". Le placement de la tache sélectionnée
dépend de la position de la souris et de la position des hotpointde la tache. Si votre tache
actuelle a un graphique associé, les valeurs de sortie des datas de la tache seront placées
mais aussi tous les pixels noirs seront transfères sur la couche "shadow" et tous les autres
pixels non-blanc seront transfères sur la couche tronc "trunks". Seul le placement de la
tache peut être défait en utilisant le menu "Edit>Undo". Cette outil n est pas disponible
pour l édition des datas de pont réparé  CC2.

terrain flood fill tool: rempliera la zone selectionnee (case de terrain) tant que les
valeurs de terrain restent les mêmes. Remplir une map entière pour une "CCM-Big map"
prend environ 10s pour un cpu lent. L’algorithme utilisé est un non optimisé non-
recursive ligne de remplissage (pour ceux qui sont effraye d obtenir un tas de
débordement). Pour travailler proprement cet outils a besoin d un maximum de mémoire
RAM. Ne l utilisez pas dans des conditions  limites de RAM. Cet outil n est pas
disponible en mode d édition de données du pont réparé CC2.

L écriture de valeurs négatives des élément de terrain est seulement possible si il est actif dans la
fenêtre "Preferences" section "Terrain Elements file". L enregistrement des datas terrain est
seulement possible si il n y a pas de protection en écriture. La protection en écriture peut être mise
sur on/off dans la fenêtre "Terrain" et dans "Data actions" section "Terrain".
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Le popup-menu "Pen size": utilisez ce menu pour sélectionner l actuelle taille de pinceau
élévation / terrain pour les outils "terrain pencil", "terrain line", "elevation pencil",
"elevation line", "elevation increase" and "elevation decrease".

Outils edition de l’elevation:

select specific elevation: utilisez ce menu pour sélectionner l élévation actuelle.

elevation pointing: cet outil sélectionne l élévation actuelle sur la case (CC2 map) ou la
case terrain (CC3-ou-+). La case sélectionnée sera en surbrillance et son altitude sera
affichée numériquement. La hauteur de l élévation et toutes les autres cases seront
montrées seulement si les cases adjacentes ont  une valeur différente.

elevation selecting tool: cliquer sur une case d élévation pour utiliser cette élévation
comme valeur. Alternativement vous pouvez aussi sélectionnez cette valeur via le menu
"select specific elevation".

elevation pencil: cliquez avec cet outil sur une case élévation (CC2 map) ou une case
terrain (CC3-ou -+) changera le codage élévation de la case par la valeur sélectionnée
dan s le menu précèdent. La taille du pinceau dépend de la sélection faite dans le menu
"Pen size".

elevation brush tool: pour les maps CC3-ou-+ cet outil affectera le codage en élévation
actuel a la carte entière. Pour les maps CC2 la case d élévation en surbrillance et ces
voisines prendront cette valeur.

elevation increase: augmentera la valeur des cases en surbrillance au pas de 1 a 1. la
taille du pinceau dépend de la sélection faite dans le menu "Pen size".

elevation reduce: diminuera la valeur au pas de 1 a1 des cases sélectionne en
surbrillance. La taille du pinceau dépend du choix fait dans la menu "Pen size".

elevation line tool: similaire a l outil "terrain line". La taille du pinceau dépend du choix
fait dans la menu "Pen size".

elevation flood fill tool: similaire a l outil de remplissage du terrain "terrain flood fill".

Outils edtion des LOS:

LOS pointing: prenez cet outil pour sélectionner la case actuelle de déploiement. Cette
case sera mise en surbrillance. Le LOS de cette case et des autres sera montre pour la
couche "LOS layer" sélectionnée. LOS peut être sur "ON" ou "OFF" (= ligne de tir libre
ou bloquée). Les cases "deployment tiles" avec le LOS sur "ON" seront vu clairement,
celles avec (bloquées) LOS sur "OFF" auront un motif par dessus. La couleur de ce
motif peut être choisit dans les thèmes de couleur. Si vous cliquez avec "LOS pointing
tool" sur différentes cases, vous obtiendrez des résultats differents, car chaque case peu
avoir un LOS différent des autres. C est normal.  -  Tous les outils d édition des LOS
sont seulement disponible si la table des LOS est présente en RAM (via générer ou
via charger).

select LOS layer: dans CC le LOS ne défini pas seulement la ligne de tir d une case a
une autre. Il y a 4 définitions pour la relation entre les LOS:
1. Soldier viewing Soldier (abbreviation SvS),
2. Soldier viewing Vehicle (SvV),
3. Vehicle viewing Soldier (VvS),
4. Vehicle viewing Vehicle (VvV).
Je ferai référence a ces quatre relations LOS comme "couches LOS". Il y en a 4, car cela
est défini pour tous les jeux CC depuis CC2. Le dossier contient la relation entre ces 4
bit-fields, pour chaque case de déploiement5.
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3. Vehicle viewing Soldier (VvS),
4. Vehicle viewing Vehicle (VvV).
Je ferai référence a ces quatre relations LOS comme "couches LOS". Il y en a 4, car cela
est défini pour tous les jeux CC depuis CC2. Le dossier contient la relation entre ces 4
bit-fields, pour chaque case de déploiement5.

set LOS visible: En utilisant cet outil ou le suivant vous ne changerez pas la case
actuelle "deployment tile" mais vous pourrez mettre le LOS sur "ON" pour la case sur
laquelle vous avez clique (usuellement le LOS est sur "ON" pour chaque case. Vous
contrôlez ainsi l efficacité du calcul des LOS en vérifiant si le LOS est bien sur   "ON"
pour toutes les cases).

set LOS invisible: avec cet outil vous pouvez mettre le LOS sur "OFF" pour les
relations entre l’actuel case déploiement en surbrillance et la case ou vous avez clique
avec votre souris.

LOS invert: avec cet outil vous pouvez inverte le LOS.

select LOS write-through mode: au moment ou le "modus operandi" est
sélectionnable: écrire avec le "set LOS visible" et "set LOS invisible" seulement pour
activer le"LOS layer" sélectionnée ou (pour faire l édition ou la correction du LOS un
peu plus vite) en écrivant avec cet outil sur les 4 couches LOS en même temps (mais
seulement une seule couche sera visible dans la fenêtre d édition).

Outil d édition du roof :

roof pointing: sélectionnez avec la souris un roof et mettez le en surbrillance (= faire de
lui l actuelle entrée roof). Si la "fenêtre d information Roof" est visible, alors toutes les
valeurs d entrée du roof (en incluant les graphiques) seront portées sur cette fenêtre. Le
graphique du roof que vous verrez dans "la fenêtre d édition" dépendra de votre choix
fait via le menu "Roof>...": roof exterior view, roof interior view, blown bridge, repaired
bridge ou seulement les limites des coordonnées du roof. Le type de limite d entrée roof
qui sera montre peut être sélectionne via le sous-menu "Roof>Rectangles or
Polygons...". Attention: la vue du roof externe sera automatiquement sur "ON" en
passant en mode édition des roof! Et  la vue du pont détruit sera automatiquement sur
"ON" en passant en mode édition  de l image du pont.

switch to CC2 bridge images: seulement pour CC2: basculer en mode édition /
définition  de l image de pont détruit (et si besoin réparé). Attention: la vue du pont
détruit sera automatiquement sur to "ON" en mode édition de l’image du pont! Car il y a
toujours une image pour le pont détruit et une pour le pont réparé, ces images seront
toujours en surbrillance. Les commandes "Edit>Copy" et "Edit>Paste" affecteront une
seul et unique image.

roof rectangle tool: utilisez cet outil pour découper une zone en mode édition roof. C est
le seul outil possible en mode définition image de pont pour CC2. Il fonctionne en
glisser-lacher: la  zone découpée aura un motif peinte par dessus avec une couleur qui est
prise dans  le thème de couleur actuel6. Pour utiliser ce découpage comme nouveau roof,
vous devez utiliser l outil "define cut-out as roof or bridge image" ou la commande
"Edit>Define Roof".

                                                  
5 Cpl_Filth wrote in this comment in his cclos.h: ...file is made up of <number of deployment tiles> * 4 *

<Ceiling(number of deployment tiles / 8)> byte rows; each row is a bitfield (0 can't see, 1 can see) from that mega tile
to every other mega tile; the 4 rows correspond to: soldier viewing soldier, soldier viewing vehicle, vehicle viewing
soldier, vehicle viewing vehicle; vehicle is used for standing soldier; los files are only used for strategic ai and
therefore have no effect on 2 player games; a file with all zeros if valid but the AI wouldn't play worth a shit.



MAFI: 5CC – The Manual (PC- & Mac-version) 22

prise dans  le thème de couleur actuel6. Pour utiliser ce découpage comme nouveau roof,
vous devez utiliser l outil "define cut-out as roof or bridge image" ou la commande
"Edit>Define Roof".

roof polygon tool: encore un outil pour un couper coller pour l édition des roof,
compatible avec "le concepts des12 sommets" des fichiers  roof de CC3-ou-+. Cet outil n
est pas disponible pour le couper coller image du pont CC2. Cliquer avec la souris sur la
marge de votre zone de polygone (jusqu a 12 points sélectionnes, je recommande d
utiliser le bord haut gauche comme point de départ). Si le dernier clic est assez prêt du
point de départ, alors 5CC fermera automatiquement le polygone, autrement il fermera
quand le 12eme point sera sélectionne. La sélection aura motif peint dessus avec la
couleur choisit dans l actuel color theme2. pour l utiliser comme nouveau roof, vous
devez utiliser l outil "define cut-out as roof or bridge image" ou le menu "Edit>Define
Roof". Une fois sélectionné, vous pouvez basculer sur "roof rectangle tool" pour utiliser
le rectangle environnant comme le couper coller (vous pouvez revenir en arrière tant que
vous n avez pas définit le couper coller comme roof). Cela vous donne (aussi en mode d
edtion CC2 map) l opportunité de sélectionner les bords d une construction même si
vous voulez définir les rectangles et non les polygones. Si vous utilisez cet outil pour
définir les roofsde CC2, le polygone sera automatiquement converti dans le rectangle
environnant correspondant.

define cut-out as roof or bridge image: meme effet que la commande "Edit>Define
Roof". Cet outil definiera la zone sélectionnée de la map (par l outil rectangle tool ou
polygon tool) comme une entrée roof, en plaçant les coordonnées du roof (et les
somment dans la cas  des roofs CC3 ou plus) et en coupant la zone du background. Ce
couper coller sera utilise pour les vues roofs extérieures et sera aussi mis
automatiquement sur le clipboard (technique introduite par Chris Ellen dans CCEdit).
Vous pouvez utiliser le graphique du clipboard dans votre programme de dessin favori
pour peindre les vue intérieure par dessus, le copier a l’inverse vers le clipboard,
basculer sur 5CC, sélectionner "interior roof view" sur ON et coller la vue interne
comme entrée en surbrillance de roof. La raison de ce principe est que vous n avez pas a
vous préoccuper de la taille du couper coller. Si vous ajoutez une vue background avec
les intérieurs peint dans la seconde couche background (via le commande
"File>Add...>Add interior background picture..."), un couper coller de cette couche sera
transfère a la vue roof intérieur quand la commande "Edit>Define as Roof" est utilisée.
Une technique introduite par Cpl_Filth pour Groof. Recommande pour les maps avec
plus d un seul roof ou pour les maps avec des roofs entrelaces.

p

roof erase tool: en sélectionnant "Interior roof view ON" cet outil effacera image de la
vue interne de l actuel entrée roof en surbrillance. Si vous avez "Exterior roof view ON"
(ou CC2 bridge image view ON) cet outil écrasera entièrement l entrée roof (ou bridge)
sans vous prévenir. C est la même choses avec la commande "Edit>Clear" et peut être
annuler via la commande "Edit>Undo".

Fenêtre "Terrain Elements Table"

Cette fenêtre contient une liste de 3 colonnes. La première concerne le numéro de classe des
éléments de terrain de l actuel "Terrain Elements File", la seconde colonne correspond au non des
élément de terrain et la troisième changer la protection en écriture pour les éléments de terrain (par

                                                                                                                                                                        
6 

a bug in certian MacOS-X environments: the pattern might vary if you are using some very light grey colors.
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défaut unchecked = sans protection en écriture). Les catégories sont repérées par un rectangle vert
entourant le nom. Ces catégories sont définit par l utilisateur. Voir page 11f de ce manuel. Si l
actuel "Terrain Elements File" ne contient pas une colonne "Category", vous verrez seulement une
seul catégorie avec un carre vide. Les catégories "Négative value" (pour des valeurs inférieures a
zéro) et "Unknown value" sont réservés et générées par 5CC a chaque chargement d une nouvelle
map: cette catégorie réservée, contiendra les valeurs du terrain trouvée dans la map non défini avec
les valeurs par défaut du fichier "Terrain Elements". La catégorie "Negative value" s ajoutera
automatiquement si vous avez active "add '-1' to terrain tables in RAM" dans la fenêtre
"Preferences" section "Terrain Elements File". Voir page 12 du manuel.

Ouvrez une catégorie en cliquant sur son triangle de divulgation / plus-icon et sélectionnez une
entrée de terrain pour changer l actuel élément de terrain pour l outil d édition de terrain a utiliser
dans la fenêtre "Editing window". Si vous cliquer sur l en-tête de la listbox, la colonne se classera
par ordre alphabétique (c est pourquoi j ai entré les nombres avec les zéro). Quand vous élargissez
la fenêtre vous verrez plusieurs colonnes avec la taille du terrain, son niveau et les définitions des
catégories. Dans des conditions normales, ces valeurs sont nécessaires pour éditer une map. Un clic
droit sur la souris (CTRL-mouse click sur Mac) fera apparaître un menu popup qui vous permettra
de choisir différents critères, changer la taille des font’s ou passer de la vue "grouped" a la vue
"show all" et inversement.

Fenêtre "Coordinates"

Cette fenêtre montrera la position du pointeur de la souris dans le menu "Editing window" par
rapport au pixel de la map (compte de 0,0 = coin haut gauche) et traduit dans les coordonnées d
élévation et de "deployment tiles". Il y a aussi une minimap (qui est identique a la mini map du
moniteur dans le jeu (MMM) graphic). La carte actuelle du couper coller dans la fenêtre "Editing
window" est montrée comme un rectangle par cette minimap. Cliquer sur cette minimap changera le
couper coller de la fenêtre "Editing window". Et les valeurs des éléments du terrain et d élévation
sous le pointeur de la souris apparaîtront ici.

Fenêtre "OVM" and "MMM"

Cette fenêtre est seulement capable de montrer les graphiques OVM et MMM. L edition n est pas
possible ici. Pour changer les graphiques des OVM et/ou MMM  utilisez la commande
"File>Import..." ou le sous menu "File>Generate...".

Fenêtre "Map properties"

Ici vous pouvez contrôler les noms des fichiers charges. Les datas marquées avec une icône de
pinceau ont été modifiées. Vous aurez aussi les informations concernant la taille de la map.

Fenêtre "Roof informations"

Si vous êtes en mode d éditons des roofs, cette fenêtre contiendra toues les datas du roof en
surbrillance (avec le nombre total des entrées roof). Pour des raisons de compatibilité 5CC générera
une base de vos 4 sommets (décrivant les rectangles roof) idem pour les entrées roofs de CC2. Vous
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pouvez changer tous les entrées numériques (excepte pour le nombre de séquence des entrées roof
et  pour la compensation graphique) dans cette fenêtre et vous pouvez écrire ces changements  en
retournant dans les entrées roof par le menu "Editing window" en pressant le bouton "Store changes
back". Les vues graphiques des roofs extérieure et intérieure ne sont pas éditables ici. Utilisez plutôt
le menu "Editing window".

(ce screenshot montre une entrées roof pour CC2-map Djedeida Tigers avec le menu "Roof informations
window". Les sommets sont calcules pour un roof CC2, aussi, mais ils ne sont pas édités. Cette fonction est
seulement disponible a partir de CC3.)

Fenêtre "Visible layers"

Apres le chargement/création d une map cette petite fenêtre apparaîtra (normalement en haut du
titre de la fenêtre "Editing"). Dans la partie gauche de cette fenêtre il y a 3 boutons pour basculer
entre les couches" visibility of the BGM", ombres et tronc. Les cartes sans arbres ni ombres et sans
fichiers image ombres et arbres auront les boutons désactives. Mettre le "BGM layer" sur off vous
donnera un fond blanc. Cela ne veux pas dire que le BGM est efface!

Dans la partie droite de cette fenetre, les valeurs du terrain et de l élévation sélectionne seront
montrées ou le mode d édition sélectionné. Le placement de cette fenêtre diffère entre Mac et PC.
Voir la section sur la fenêtre "Preferences" du manuel page 12.
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Fenêtre "Trees"

Cette fenêtre a été conçu avec le concept de couche (layer) et l outil "tree shadow patch" dans la
version v1.03 de 5CC. Le but était de donner a l utilisateur la possibilité de placer des motifs définis
par l utilisateur des éléments de terrain. Simultanément un graphique relationnel serai placé sur l
image de fond. Et tache graphique consistuerai des ombres et des solides. Cette particularité est
principalement nécessaire pour placer les arbres sur une carte CC. Sans cet outil la création du
background doit être réalisée avec les arbres dessus (CC2: les troncs et les petites ombres centrales;
dans les autres versions: un petit tronc et une ombre  d arbre complet). Le problème était toujours
que l artiste devait savoir et respecter les limites de la grille de CC lors du placement des arbres et
après sur chaque arbre les coder avec l éditeur de terrain. Cpl_Filth  a inventer son propre
programme pour le faire il y a quelques années. 5CC combine maintenant tous ces outils en un seul.
Et cela vous donne l opportunité de l utiliser pour les arbres mais aussi il peut servir dans le
placement des constructions et des motifs du terrain sans graphique apparente (comme les lignes de
cote, courants, routes etc.).

Avant d utiliser l outil "tree shadow patch tool" de la fenêtre"Tools" vous devez créer le chemin d
accès. Les graphiques nécessaires doivent être réalisées en dehors de 5CC et importes en TARGA
16-bit. Il est aussi possible de le faire via le clipboard, mais dans ce cas votre graphique ne sera pas
sauvegarde lorsque vous quitterez 5CC. Le chemin doit être fait dans la fenêtre "Trees" (avec la
commande "Edit>Select/Edit tree shadow patch..." de la barre de menu pour la faire afficher sur le
devant).

La partie gauche de cette fenêtre montre une liste contenant les chemins définis. Leurs définitions
sont enregistrées dans le fichier préférence "5CC.ini". Le chemins pré-definis peuvent être édites,
effaces et 5CC fonctionnera sans aucun chemin défini dans le fichier préférences. Cliquez sur la
liste pour changer les noms des entrées. Le nom est seulement pour vos propres références
personnelles. Les espaces vierges ne sont pas autorisés. Trier le liste n est pas possible et seulement
permis si vous éditez le fichier "5CC.ini" avec un éditeur de texte externe. Dessous cette liste vous
avez 3 boutons: le <+> button pour ajouter une entrée, le <-> pour supprimer une entrée et le <d>
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pour dupliquer une entrée. Utilisez le triangle d en-tête pour réduire la taille de la fenêtre, vous
aurez alors seulement la liste a l écran.

La partie droite de cette fenêtre montre un rectangle noir. La taille maximum des ombres d arbres
est de 20x20 en "terrain tiles". Les coordonnes commencent dans le coin haut gauche, a partir de
0,0. Apres avoir sélectionné une entrée de la liste la prochaine étape a réaliser est de définir la taille
de votre tache. Utilisez le popup menu"Width" and "Height" pour sélectionner la taille. Utilisez le
menu popup "Image" pour choisir un graphique pre-defini ou importer un fichier externe. Si vous
importer un fichier  externe, soyez sur qu il est en TARGA 16-bit. 5CC gardera en mémoire le
chemin dans son fichier préférences. Si vous déplacer ce fichier de votre HD, 5CC ne le retrouvera
pas et vous devrez refaire le lien avec ce fichier.

Les graphiques associes avec des ombres d arbres doivent suivrent ces règles:
- les graphiques externes doivent être en TARGA 16-bit,
- peuvent être de n importe quelle taille (et habituellement plus large que la tache défini dans

la zone de donnée),
- seule le coin haut gauche de 200x200 pixels sera visible dans la fenêtre "Trees", mais la

totalité de l’image sera placée quand la tache est utilisée,
- les  pixels blancs seront toujours traits comme "transparent",
- les pixels noirs seront traités comme des ombres"shadow", ces pixels seront transfères vers

la couche "shadow". Quand l opacité est inférieure a 100, les pixels seront places par rapport
a l échelle de gris de cette couche. Si vous utilisez des multiples taches avec une opacité
différente vous aurez vous aurez différents tons de gris dans la couche "shadow" (exemple:
petits arbres mois opaques = moins d ombres, grands arbres plus opaques, constructions
solides = forte opacité). Dans ce cas je recommande fortement de désactiver
"double/overlaying shadows" dans la fenêtre "Preferences", section "Layers". Vous mettrez
en premier les taches avec forte opacité puis celles avec mois d opacité en dernier. Ainsi
vous aurez les petites ombres ajoutées seulement dans la zone ou les ombres ne sont pas
encore placées.

- Tous les autres pixels ni blanc/ni noir seront transfères à la couche troncs "trunks". Votre
graphique ne doit pas contenir plus de pixels que  besoin. Et il ne doit pas contenir de pixels
d ombre.

La couche sera placée par dessus le fond"background" dans la fenêtre "Editing". Leur visibilité
pourra être changée en utilisant les boutons de la fenêtre "Visible layers". Leurs concepts de
stockage sera examines plus tard.

Comme mentionne plus haut vous pouvez définir l opacité des pixels des ombres. Utilisez le menu
popup "Opacity" pour cela. Dans ce menu vous pouvez voir des boutons pour sélectionner la valeur
de votre terrain pour vos ombres d arbres. Ils ne seront actifs que si vous avez pris la bonne taille
pour vos taches. Le "terrain pencil tool" et le "terrain selecting tool" travail de la même façon que
les outils de la fenêtre "Tools" (taille du pinceau = 1 seulement!). Vous pouvez sélectionner le
terrain désiré a partir de la fenêtre "Terrain Elements Table" comme vous l aurez fait lors de l
édition de la map. Utilisez "terrain erase tool" pour mettre les éléments de terrain sur "transparent"
(ce n est pas possible en mode édition de map). La transparence des éléments de terrain ne changera
pas le contenu de votre map quand les ombres seront placées. Si vous sélectionnez une valeur
négative "-1" d ans la fenêtre "Terrain" cela aura le même effet que l utilisation du menu
"terrain erase tool".

Utilisez "hotpoint center tool" pour définir le "Hotpoint" de la tache. Le "hotpoint" est l élément de
terrain de cette tache qui sera place sur la map avec le pointer de la souris. La fenêtre "Trees" sera



MAFI: 5CC – The Manual (PC- & Mac-version) 27

montrée dans le coin droit inférieur des coordonnées de l actuel hotpoint (compte de 0,0 = bord haut
gauche de la tache) e de l élément de terrain sélectionné. Sélectionnez la valeur du terrain dans la
fenêtre "Terrain Elements Table" fera aussi effet dans les fenêtres "Editing" et "Trees".

Maintenant prenons l exemple du screenshot de la page précédente: sélectionnez la première entrée
"CC2 Small tree". Elle utilise une donnée de 3x3 avec des bord transparent (pour le moment aucune
valeur d élément de terrain n est sélectionnée = transparence est sélectionnée). Au milieu la valeur d
élément de terrain est sur "small tree" et le hotpoint est localise sur cette position. Les éléments de
terrain "abandonnes" sont groupes autour de ce center/hotpoint/trunk comme une croix. Cette tache
est associe avec un graphique intrinsèque qui est plus large que les données de la tache. Pour CC2 il
n est pas nécessaire de définir entièrement l ombre de l arbre sur l image de fond, car les fichiers de
terrain de CC2 contiennent déjà ces graphiques (je ne sais pas pourquoi les concepteurs du jeu on
oublie cette particularité a partir de CC3). Pour CC2 un tronc central avec autour son ombres est
utilise dans les maps originelles.

Concept de double couche

When you use the "tree shadow patch tool" for the first time on a map, 5CC will create three (3)
additional background graphics to store the graphics pasted in by this tool. This patch placement
can be redone using the command "Edit>Undo", but the additional background graphics will remain
in RAM until you load/create a new map. These additional background graphics will be used by
5CC like layers with transparency (white pixels). You can toggle the visibility of these layers using
the buttons in the window "Visible layers".

Quand vous avez placer les ombres d arbres, vous aurez changer les datas de votre map. Mais vous
n aurez pas changer la graphique interne, le graphique BGM, parce que les ombres et les troncs sont
enregistres dans une autre couche. Essentiel:

- Avec les commandes "File>Save" ou "File>Save as..." les nouvelles datas de map seront
sauvegardées dans un nouveau dossier datas CC (dans le cas de "File>Save" : en écrivant
par-dessus les datas existantes).

- Votre fichier BGM ne sera pas sauvegarde avec la commande "File>Save". Seulement les
couches "shadow" et "trunks" seront enregistrées dans un fichier séparé TARGA  (on peut
prendre la même dossier ou est votre  BGM).

- Quand vous utilisez "File>Save as..." votre fichier BGM sera enregistré et les couches
"shadow" et "trunks" seront enregistrées dans un fichier séparé TARGA  (on peut prendre la
même dossier ou est votre  BGM).

- Vous pouvez vous servir du sous-menu "File>Export>Export BGM / background" pour
créer un BGM (ou une image) contenant toutes les couches de votre BGM initial.

- Les OVM et MMM ne seront pas modifie par le placement des arbres et des ombres.
- Les  entrées Roof  / graphiques roof  ne seront pas modifier non plus.
- Les images du pont CC2 ne seront pas changer par le placement d ombres et des arbres.
- Si vous devez interrompre votre  travail avec 5CC vous pourrez le recharger manuellement

dans le dossier de sauvegarde. 5CC ne charge pas automatiquement les TARGA des ombres
et des arbres.

Pourquoi sauvegarder les couches dans différents dossiers? Dans la plus part des cas les ombres
dans 5CC doivent être retravaillée plus tard. Pensez simplement qu une ombres ne peut pas se
trouvez sur un objets plus haut qu elle! Dans ce cas l ombre doit être couper. Si vous enregistre vous
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couches dans un dossier différent vous les importerez sans problème dans votre logiciel graphique
habituel.

Je vous recommande d abord de créer votre graphique BGM  sans les ombres d arbres réalisées
dessus la map. Cette étape peut être effectuée dans les dernières. La réalisation de la définition du
pont CC2 et le calcul des LOS se font en dernier.

Fenêtre "LOS actions"

Générer un LOS (= ligne de tir) se fera dans la RAM par 5CC. Le résultat pourra être sauvegarde
plus tard par les commandes "File>Save", "File>Save as..." ou "File>Export>Export LOS file...".
La fenêtre "LOS actions" offre divers possibilités pour  manipuler entièrement la table de référence
des  LOS ou une seule des couches LOS:

1. Soldier viewing Soldier (abbrege SvS),
2. Soldier viewing Vehicle (SvV),
3. Vehicle viewing Soldier (VvS),
4. Vehicle viewing Vehicle (VvV).

La première section de la fenêtre window "initialize complete LOS" vous permet de générer les
LOS de 4 manières différentes:

- sans checker les valeurs du terrain (en respectant seulement l élévation),
- en émulant le chemin original comme  décrit par Gerry Shaw "Tin Tin", "JM" et Vincent

Viaud (c est seulement une émulation et non le code original, cette méthode analyse les
obstacles et l élévation du terrain par étape de 10x10 pixels de terrain),

- analyser les LOS par étape en  élévation par pixels de 40x40 (plus rapide mais moins précis),
- analyser les LOS par étapes en case de déploiement "deployment tiles" de 120x120 pixels

(moins efficace, mais très rapide).
Pour toutes ces méthodes il es possible de restreindre le calcul des distances du LOS de "no
limitation" = time consuming to "nearest neighbours only" = very fast = emulating "fog". Et ces
restrictions peuvent être faites sur chaque couche LOS individuellement.

La seconde section de cette fenêtre "set entire layer" peut être utilise pour initialiser une seul couche
LOS de "LOS on" ou "LOS off". La troisième section "layer copy" peut être utiliser pour copier les
données d’un LOS en entier vers une autre couche LOS.

La méthode qui génère le calcul des données terrain et élévation requière un fichier "Terrain
Element " charge dans la RAM. Autrement seul la méthode "Generate LOS without checking the
terrain values" fonctionnera.  Avant de générer le LOS, la routine analysera les valeurs négatives de
la map  entière et vous avertira si il y en existe. Le LOS sera fait n importe comment parce que les
valeurs négatives ou inconnues du terrain dans les datas de la map seront ignorées et seul l élévation
sera pris en compte pour le calcul du LOS.

La méthode qui génère les LOS utilisés par 5CC requière de multiple analyse de la ligne de tir a
partir d un "deployment tile"vers les tous autres "deployment tiles". Si vous utilisez la  première
méthode, 5CC calculera la map a partir du centre pour chaque case de déploiement vers toutes les
autres en analysant chaque  case d élévation de  terrain (10x10 pixels), niveau de terrain et hauteur
de terrain. Dans la cas de la deuxième méthode de calcul non seulement la totalité de l analyse est
réduite en utilisant des cases plus larges, mais aussi en calculant les valeurs moyennes ( élévation,
niveau de terrain et hauteur de terrain) de ces cases avant de générer les tables du LOS. Ceci
nécessite un peu plus de RAM.
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Tactiques

Définition des Roof

Petite introduction pour définir les roofs avec 5CC. Le moyen le plus facile est celui utilisé par
Cpl_Filth pour crée une nouvelle  map:

- codez votre  (terrain et  élévation) avec 5CC.
- Créez 2 fichier graphique BGM: un avec les vues extérieurs, et l autre avec les vues

intérieures. Les 2 fichiers BGM auront la même taille que votre carte.
- Utilisez le menu "File>Import...>Import background as 16-bit TARGA..." pour importer la

vue extérieure.
- Utilisez le menu "File>Add...>Add interior background 16-bit TARGA..." pour importer la

vue intérieure.
- Basculez en mode edition des roofs via "tools window", outil "roof pointing".
- mettez roof exterior view sur "ON" en utilisant la commande "Roof>Roofs" (Si ce n est pas

déjà fait). Puis définissez vos roofs selon la sequence suivante:
- pour les mas CC2 prenez l outil "roof rectangle", a partir des maps CC3 et + prenez l outil

"roof polygon" (mais vous pouvez utilisez les deux outils, 5CC ajustera automatiquement
les roofs pour  CC2 en rectangles si ils étaient définis auparavant par l outil "roof
polygon"),

- utiliser la souris pour pointer et faire un couper coller de la zone sélectionnée ou utilisez
la souris pour pointer chaque coin du polygone,

     

- utilisez l outil "define roof" ou la commande "Edit>Define as roof" pour définir la zone
comme entrée roof. Parce que vous avez 2 couches BGM (extérieur et intérieur)
présentent, 5CC créera les 2 roofs automatiquement (quand vous avez utilise l outil "roof
polygon", la zone surlignée sera remplacée automatiquement avec une couleur blanche =
zone transparente, mais seulement pour le cas des maps  CC3-ou +. Dans le cas des maps
CC2 les entrées roofs seront automatiquement des rectangles (images ci dessous).
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- répétez cette opérations autant de fois que nécessaire.
- Sauvegardez vos changements.

Si vous voulez changer une entrée existante: je vous recommande de faire un back up avant:
- Passez en mode edition des roofs via "tools window", outil "roof pointing",
- Sélectionnez le roof a changer avec cet outil (il sera alors en surbrillance),
- Mettez la vue du roof externe sur "ON" (si ce n est pas déjà fait) via la

commande"Roof>Roofs",
- Utilisez le menu "Edit>Copy" pour transfert le graphique vers le clipboard,
- Utilisez votre logiciel de dessin pour importer ce couper copier, sauvegardez le,
- Retournez dans 5CC, mettez la vue du roof intérieur sur "ON" via le menu "Roof>Interiors",
- Prenez la commande "Edit>Copy" pour transférez le graphique intérieur vers le clipboard,
- Utilisez votre logiciel de dessin pour importer cette image, sauvegardez la, aussi,

Maintenant vous pouvez utiliser plusieurs moyens pour faire les changements:
- Effacez le roof en surbrillance avec l outil "roof erase" et définissez en un autre.
- ou prenez "roof informations window" pour changer les coordonnées.

Vous devez alors ajuster les entrées graphique du roof:
- utilisez la commande "Edit>Update all roof graphics..." pour corriger le graphique extérieur

(et peut être l intérieur aussi si la couche BGM intérieur est chargée),
- mettez la vue du roof  intérieur sur "ON" via "Roof>Interiors",
- passez sur votre nouveau graphique intérieur en utilisant le menu "Edit>Paste" (après avoir

effectue vos modifications avec votre logiciel de dessin).

Une autre façon de créer votre roof si vous avez uniquement le graphique externe de prêt:
- coder la map de base (terrain et élévation) avec 5CC.
- créez le graphique BGM avec la vue extérieure, sa taille doit être identique a celle de la map

de base.
- Utilisez la commande "File>Import...>Import background as 16-bit TARGA..." pour

importer le graphique de la vue extérieure.
- Bascule en mode edition des roofs via "tools window", outil "roof pointing".
- Mettez la vue du roof extérieur sur "ON" avec la commande "Roof>Roofs" (si ce n est pas

déjà fait). Puis définissez vos roofs en suivant cette procédure:
- pour les maps CC2 sélectionnez l outil "roof rectangle", pour CC3- et + sélectionnez l

outil "roof polygon",
- utilisez le pointeur de la souris pour" pointer et lâcher" (point and drag) la zone voulue ou

utilisez la souris pour pointer point par point le polygone,
- utilisez l outil "define roof" ou la commande "Edit>Define as roof" pour définir la zone

sélectionnée comme entrée de roof. 5CC créera le graphique roof extérieur
automatiquement et le copier avers le clipboard automatiquement (quand vous avez
utilise l outil "roof polygon", la zone surlignée sera remplacée automatiquement avec une
couleur blanche = zone transparente, mais seulement pour le cas des maps  CC3-ou +.
Dans le cas des maps CC2 les entrées roofs seront automatiquement des rectangles).

- passez sur votre logiciel de dessin, créez votre nouveau graphique et utilisez la
commande "Edit>Paste" pour passé sur le graphique extérieur. Faites vos changement
nécessaires pour obtenir votre vue intérieure (évitez l anti-aliasing). Copier votre nouveau
graphique vers le clipboard (il doit être de la même taille que la vue extérieure).
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- retournez dans 5CC, mettez la vue du roof intérieur sur "ON" avec le menu
"Roof>Interiors".

- vous devriez maintenant voir un rectangle/polygone noir en surbrillance.
- utilisez la commande "Edit>Paste" pour passer sur votre graphique intérieur.
- répéter cette étape pour toutes vos entrées roofs.

- Sauvegardez votre travail.

Apres avoir défini tous vos roofs, vous pourrez alors ajuster la définition du terrain a vos
graphiques. Pour voir la vue intérieure mettez simplement la vue intérieure sur "ON" avec la menu
"Roof>Interdits" quand vous êtes en mode d édition de terrain (utilisez l outil "terrain pointing" ou
tout autres outil d édition de terrain).

Définition de l´image CC2 pont

Utilisez la même méthode que décrit pour les entrées roofs:
- codez votre base de terrain (terrain et élévation) avec 5CC.
- créez le graphique BGM avec la vue extérieure, de même taille que votre map de base.
- Utilisez la commande "File>Import...>Import background as 16-bit TARGA..." pour

importer la vue extérieure du graphique.
- Basculez en mode edition image de pont

via la commande "tools window", outil
"switch to CC2 bridge images".

- mettez la vue du pont détruit sur "ON" avec le menu "Roof>Bridge blown" (si ce n est pas
déjà fait). Définissez votre unique et seule image de pont détruit en utilisant la séquence
suivante:

-      sélectionnez l outil "roof rectangle",
- utilisez le pointer de la souris pour

pointer et lâcher (point and drag) la
zone désirée
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- utilisez l outil "define bridge
image" (même bouton que
"define roof") ou la commande
"Edit>Define as blown bridge"
pour définir la zone désirée
comme image de pont détruit.
5CC prendra la sélection
comme image de pont détruit
automatiquement et le copier
avers le clipboard.

- vous vous demanderez si vous
aurez les mêmes coordonnées
avec l image du pont réparé. La
réponse est "NON" si vous ne
voulez pas avoir une image de
pont réparé.

- passez sur votre logiciel de dessin, créez un nouveau graphique et utilisez la
commande "Edit>Paste" pour passer sur votre graphique issue du couper coller.
Faites vos changements pour réaliser l image du pont détruit (avoid anti-aliasing).
Copier ce nouveau dessin vers le clipboard (toujours de même taille que le couper
coller précèdent).

- retournez dans 5CC, laissez la vue du pont détruit sur "ON" avec la
commande"Roof>Bridge blown".

- vous devriez maintenant voir la zone de votre nouveau graphique en surbrillance.
- utilisez la commande "Edit>Paste" pour passer sur l image du pont détruit.

- si vous avez besoin de l image du pont réparé, mettez la vue du pont réparé sur "ON" en
utilisant la commande "Roof>Bridge repaired". Définissez alors votre seule et unique image
de pont réparé en appliquant le principe suivant:

- si vous désirez changer les coordonnées du graphique de votre pont réparé,
définissez en un nouveau en utilisant les outils "roof rectangle" et "define bridge
image". Demandez vous si vous voulez écraser les définitions déjà existantes. Vous
devez utilisez la commande "Edit>Copy" pour obtenir cette nouvelle sélection vers
le clipboard. Transferez votre selection vers votre programme de dessin.
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- passez sur votre logiciel de dessin, prenez l image du pond détruit et réalisez vos
modifications pour obtenir l image du pont réparé (avoid anti-aliasing). Si la zone
de votre pont réparé a des coordonnées différentes de celle de votre pont détruit,
copiez cette image par dessus l image précédente issue de la zone sélectionnée du
pont réparé de 5CC (pour obtenir une taille d image correct). Copier ce nouveau
graphique vers le clipboard (toujours avec la même taille que le précèdent couper
coller).

- retournez a  5CC, gardez la vue
du pont réparé sur "ON" en
vous servant du
menu"Roof>Bridge repaired".

- vous devriez maintenant voir le
graphique BGM sélectionné en
surbrillance.

- utilisez la commande
"Edit>Paste" pour passer au
graphique du pont réparé.

- sauvegardez votre travail.

Définition des datas CC2 bailey pont

A ce stade CC2 passera sur les nouvelles datas de terrain pour la zone de pont réparé (si le XXX
Corps a atteint le pont, seulement pour en mode opération/campagne). Et bien sur le graphique du
pont réparé. Le XXX Corps utilise le pont Bailey pour traverser la rivière (regardez comment cela a
fonctionne dans le film  "Un pont trop loin" (A Bridge Too Far)). Ces datas de terrain sont
localisées dans le fichier data "Map###" derrière le premier "#". Seul les cases élévation seront
redéfinies ici. 5CC est le premier outil pour éditer/créer ces datas facilement:
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- codez complètement votre map (terrain
et élévation) avec 5CC.

- codez vos graphiques BGM et roof,
- faites les graphiques de vos ponts

détruits et réparés,
- définissez les datas du pont bailey en

dernière étape:
- mettez la vue du pont réparé sur "ON"

via le menu "Roof>Bridge repaired",
- utilisez l outil "switch to CC2-repaired

bridge data editing",
- vous devriez voir le graphique entier de

votre BGM avec un motif gris (light
grey), indiquant que la zone du pont
bailey n est pas défini.

- utilisez le pointer de la souris (MacOS:
flèche avec un "B" vert) pour définir l
élévation que vous désirez avoir pour le
pont bailey. Pour effacer plus d une
case élévation utilisez la commande
"Edit>Clear". La zone définie passera
en surbrillance (en violet) et les motifs
gris (light grey) seront enlevés.

- utilisez les outils "terrain pencil",
"terrain selecting", "terrain rectangle
pencil" et/ou "terrain brush" pour
redéfinir le terrain de cette zone (les
autres outils ne sont pas disponible dans
ce mode). Par défaut les valeurs de
terrain et d élévation sont copiées
quand une case d élévation est définie
comme zone de pont bailey. Désole de
vous dire que vous ne pouvez pas
changer l élévation (pour le cas ou vous
en auriez réellement
besoin,sélectionnez le terrain basique
avec les valeurs d élévation du pont
bailey, définissez la zone de datas du
pont bailey et changez l élévation
basique).
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- sauvegardez votre travail.

Pour plus de détails sur les datas et graphiques du Bailey bridge de CC2 prenez mon
guide"CC2Guide-Bridg-files_v6.pdf".
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Sources Internet utilisées et recommandées:

MICK "XE5" CONMY: CC2 Editing FAQ ("cc2eFAQ.zip"), July 1998.
MATTHEW DAVID HILLS: several texts from his site, September 1998.
ANDREW GLENN "NAKED FOOT": CC2 Map Making Guide ("MapFAQ.zip" inside the

"MapMaker.zip"), November 1998.
ANDREW GLENN "NAKED FOOT": Naked Foot’s Close Combat III Map Making Guide, Edition 2

("CC3 Map Making.doc" inside his map "zerstorer.zip", October 1999.
GERRY SHAW "TIN TIN": several file format texts from his site, 1998-2002.
DAVID R. TIDY "THE OTHER DAVE": CC2 FAQ ("CC2Faq.wri"), June 1998.
VINCENT VIAUD: source code and readmes of his tool "cclos.exe", June 1998.
FRANK FIJNEMAN: running CC2 mods from HD under MacOS, 1999.
"UGUR": a new method adding CC2 maps "http://home.wanadoo.nl/cclinks/morecc2maps.html",

January 2001.
PEKKA SAASTAMOINEN "CPL_FILTH": CC3-roof file format, readmes from his tool "3C.exe", 1999.
CHRIS ELLENS: CCEdit manual and readmes, 2000.
"SGT WILSON": "QClone.exe" tool results to get the terrain definitions of CC4-RtB.
SHANE CAMERON "SOUTHERN_LAND": Southern_land’s map making guide

("Southern_Land_Map_Guide.doc"), January 2003-2006.
"KWP": forum text relating CC3 map data heading, November 2005.
"MAFI": The Bridge-File Guide ("CC2Guide-Bridg-files_v6.pdf"), March 2001-2003.
"MAFI": The Batnames-File Guide ("CC2Guide-NewBattlesMaps_v6.pdf"), March 2002-2005.
"MAFI": The CC-series Map File Formats ("CC2Guide-TxtfMapLosRoof.pdf"), January 2006.

Quelques forum actuels pour CC:
CloseCombat HQ:   http://www.ryanross.net/cc/
CSO:  http://www.closecombat.org/
CCS:  http://www.closecombatseries.net/

French translation of this manual by Martial FFL_Jag, thanks a lot to him!

Mafi
closecombat2@claranet.de
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